歪曲劇場

LANDISK+gcc-3.4/glibc-2.3

debian.dodes.orgの(非公式)Debian distributionはgcc-3.0+glibc-2.2である。とりあえずこれでも問題ないのだけれど,woodyやsargeからソースを引っ張ってきた時に面倒なので,gcc-3.3+glibc-2.3化に挑戦。

で,これが結構大変なんだけれども(とにかくコンパイルが遅い・・・), 色々格闘して分かってきたことは,

  • gcc-3.0.4, 3.3.4の-O2は怪しい。-O0は安定しているみたい。
  • gccをビルドする時,gcc/config/sh/libgcc-glibc.verを../libgcc-glibc.verで置き換えないと,libgccが正しく作成されない。
  • gccはmake bootstrap4でビルドする(-O0なら普通のbootstrapで大丈夫かもしれない)。

今のところglibc-2.3.2はまだ動いていないのだけれど,おそらく-O0でmakeすれば動くと思う。あとは時間の問題?

posted at 18:18:07 on 2004-10-25 by ichiro - Category: Hack

Comments

No comments yet

Add Comments

このアイテムは閲覧専用です。コメントの投稿、投票はできません。